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1.0: Overview
1.1: Database System
Emerging Markets Economic Data (EMED)’s database system offers a time series manager
interface, which is a user-friendly platform to access and retrieve economic and financial
data. The system mainly consists of two components:
•
•

Database
dXtime 5.4 EMED Edition

1.11: Database
Each country in EMED database covers up to 23 sections of data. There is a corresponding
abbreviation (inside the bracket) for each section shown below:
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

National Accounts (GDP)
Production, Shipment, Inventories & Orders (PSO)
Land, Construction & Properties (LCP)
Government Revenues & Expenditures (GRE)
Domestic & Foreign Debts (DFD)
Demography & Labor Market (DLM)
Wholesale & Retail Trades (WRT)
Inflation (INF)
Balance of Payments (BOP)
Foreign Trade & Investment (FTI)
Money & Banking (MNB)
Interest & Foreign Exchange Rates (IFR)
Household Incomes & Expenditures (HIE)
Business & Corporate Activities (BCA)
Energy (ENG)
Automobiles (AMB)
Tourism Statistics (TRM)
Economic & Business Surveys (EBS)
Transport & Communication (TNC)
WB-IMF Quarterly External Debt Statistics (QED)
BIS-IMF-OECD-WB External Debt Statistics (BIS)
Daily Statistics (DAY)
Financial Market (FIN)

The structure of the database is presented like that of Windows Explorer’s. Each database
contains a number of countries; each country contains a number of sections; each section
contains a number of tables; and each table contains a number of data series.
Country Level → Section Level → Table Level → Series Level
The titles and layout of the data series are presented in a way similar to those published in
the official sources. The official data sources can be found in dXnotes (see 4.1: dXnotes)
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1.12: dXtime 5.4
dXtime 5.4 follows the fundamental Windows concept of “selection followed by action” to
access and retrieve information.
The software uses a graphical interface to view data tables and graphs. Besides, it contains
many sophisticated built-in tools for data manipulation and data extraction. dXtime is fully
compatible with many Windows based applications.

1.2: Starting dXtime 5.4 EMED Edition
There are two ways to start the program:
• Double click on the desktop icon setup during the initial installation.

•

Alternatively, select “dXtime” within the “dX, EMED Edition” program group
from the “Start” menu.

Once dXtime 5.4 EMED Edition is loaded, you will be greeted by a friendly Start Page
where you can get quick access to installed databases, remote databases, recentlyaccessed Workfiles, and to program documentation and other resources.

1.3: Initial Database Setup
If this is your first time using dXtime, you need to load the databases you’ve subscribed
to before you can access them. On the menu bar, select File > Manage Databases >
Database Setup…. A new dialogue box entitled Setup Official Databases will open.
Click the Locate… button to select your databases and press OK.
5

Click the Locate… button to find
the installed databases

**Note:
You will be able to choose this command only if the folder where databases were
installed (hard drive or local area network) has the right permissions of editing (write) or
if databases that are being accessed remotely, internet connection will be required.
To view the databases you have located and installed, click on the Databases icon
on the application toolbar or press Ctrl+O.
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Select a database and
click the OK button to
access it

2.0: Key Features
2.1: The Display: Major Components of the dXtime Desktop
Time series information is displayed within one or more windows on the dXtime desktop.
The different types of desktop windows include:
•
•
•
•

Series Directory Window, displaying series description information.
Data Table Window, displaying the data observations for one or more time series.
Graph Window, providing a graphical representation of the time series.
Notes Window, displaying explanatory and release notes for Official Databases.

2.11: The Series Directory Window
The Series Directory provides an on-screen directory of series contained within an Official
Database or Workfile. The directory serves as an outline, containing both time series and
various levels of table headings which define the overall structure of the database.
The Series Directory initially displays only the highest level of the outliner hierarchy. To
expand and collapse Sections, Tables, and Series, click on the outlining buttons displayed
beside these items.
As it expands the headings, dXtime displays the descriptions of all tables being expanded in
its status line. Press ESC at any time to cancel the operation. dXtime will show the contents
of all headings expanded up to that point.
When an official database first opens, the Data Series Directory displays the database in its
country level.
The country level expander (i.e. the “+/-“ button adjacent to each country) opens the section
level display. The section level expander then opens the data series level displaying
information such as Description, Identifier (series code), Units, Sample (sample period),
and Modified (latest update).
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Country Level

Section Level

Series Level

Alternative Ways to Expand the Series Directory
•
•
•
•

Double click on the country, section or table description
Select a country, section or table and press the “+/-“ key on the numeric
keyboard
Select a country, section or table and press “Enter” to expand or
“Shift+Enter” to collapse.
Select either the “Expand” or “Collapse” function from the View menu.

**Note:
Under the “Option” menu, select “Column” from “Series Directory”. You can adjust the
width of the display column, but remember to check “Use for new directories” to save the
settings for future use.
Data Series Selection
Selecting Adjacent Series
Data series can be selected using the mouse, the keyboard or a combination of both. To
select adjacent data series, point, hold and drag the mouse. Alternatively, select a single
series and while holding the “Shift” key, point and left click the mouse to select a whole
block of series.
Selecting Non-Adjacent Series
To select non-adjacent data series, point and left click the mouse while holding the “Ctrl”
key. Alternatively, x-marking can be used. X-marking a particular data series is activated
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when the space bar is pressed once and deactivated when it is pressed once again. When a
series is x-marked, the series is shown in “red” with “x” adjacent to its description. To
select all x-marked series in the database, hold “Ctrl +Space”. To remove all, press space
again.
**Note:
Instead of using the space bar, x-marking is also available under the View menu. To select
all x-marked series, use the “Select x-mark” from the View menu, and to remove, select
“Remove x-marks” from the View menu. Please note that x-marking cannot be used to
select data series from different database at any time.

Marked with a red “x” for easy identification

2.12: The Data Table Window
The Data Table displays the data observations for one or more series on a Series Directory.
The Data Table displays the observations for each series in a separate column. The amount
of data displayed is governed by the Timeframe (the frequency and sample period)
currently attached to the table.
After the series are selected, they can be displayed in Data Tables by selecting View >
Data or clicking on the “View Data” icon on the menu bar, or press Ctrl+D.
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“View Data” icon

Data Table of the 3 series highlighted in the example above

The most recent observation is shown at the bottom
Heading shows Series Description, Unit, Identifier, and Sample.
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Each data table has no limit on the number of series that it can hold. In this mode, the menu
changes to a “Data” menu that provides functions specific for data tables.
dX can display series with different frequencies in the same table. By default, dXtime sets
the time frame of the data table equivalent to the highest frequency among the selected
series. The data table will display the lower frequency series by spanning it across the
corresponding higher frequency observations.
The headings show the different characteristics of different frequencies.

Lower frequency data are displayed across the higher frequency observations
The dates correspond to the higher frequency observations

2.13: The Graph Window
The graph window displays a graphical representation of the data observations for one or
more series in a Series Directory. The amount of data displayed is governed by the
Timeframe currently attached to the graph. dXtime generates complete graphs for selected
series with a single command. Once generated, a given graph can be customized in many
different ways.

11

Apart from viewing the data table, the selected series can be shown as a graph by choosing
“Graph” under the View menu, clicking on the “Graph” icon on the menu bar, or pressing
“Ctrl+G”. The maximum number of data series than can be charted on a single graph is 12.
“Graph” Icon

The Graph Window of the 3 series highlighted in the example above
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The menu bar in the Graph Window offers a wide range of functions to fine tune the active
graph display.

List of icons:
Switch between line, bar and scatter plot display
Graph Title: Edit and changes titles
Graph Series: Change placement and display
Split Axes: Associate every second series with a separate right axis
Multiple Charts: Use bottom, middle and top charts.
Graph Axes: Change layout, ticks, scale, titles, grid style, and axis style.
Logarithmic Scale: Use logarithmic scales
Grid Lines: Use grid lines
Hide Legend: Use/Hide legend at the bottom
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Monochrome: Use color

Timeframe: Sets different time frame
Similar functions can also be found in the Graph menu.

Provides a set of drawing tools to annotate with text, arrows etc.
**Note:
To display the floating tool palette, right-click on the toolbar at the top of the graph
window to choose “Drawing”.
Drawing objects can be anchored to horizontal and vertical axes. This means that these
objects can intelligently reposition themselves as graphs are resized or new data is added.

2.14: The Notes Window
Daily data releases, advance release schedules, and explanatory notes for EMED Official
Databases are displayed in the Notes window. This window is displayed by clicking the
Notes button in the Series Directory toolbar, or by choosing the View > Notes command.
Whenever the Notes command is executed, dXtime attempts to display any notes pertaining
to that database’s active category or section. Afterwards, the Note drop-down list in the
Notes toolbar may be used to access other available notes for the database.
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The Notes window features a dedicated toolbar. The toolbar buttons allow you to navigate
back and forward through recently viewed notes, to refresh the display, and to select from
available notes. Use the Home button
database.

to go to the default note (home page) for the

(for more details, go to section 4.1: dXnotes)

2.2: Workfile
2.21: Workfile Concept
The structure or content of an Official Database cannot be modified by users (either on
screen or on disk). You may, however, create your own private collections of time series
using dXtime “Workfiles”.
Workfiles can be used to
• Assemble selected series from Official Databases.
• Derive new series resulting from series operations.
• Store series referenced by memorized Graphs or Data Tables.
• Save series data downloaded from a remote host computer.
• Insert and edit user-defined series.
• Store series imported into dXtime
Once selected series are copied to workfiles, users can then manipulate these series by
editing, applying calculations, inserting new series or deleting old ones and so on. Workfiles
are basically user-defined files containing original/raw data series from the database plus
user-generated information.
A workfile can be saved and re-opened at any time in the future. It can be set up so that all
information can be updated automatically from the official database and all generated
information recalculated automatically. There is also a choice to update manually (see 2.26).

2.22: Workfile Features
The Series Directory for a Workfile can easily be distinguished from that of an Official
Database by its distinctive yellow background. Its title refers to the name of the Workfile on
disk (provided the Workfile has been saved to disk), and there is always a single blank row at
the bottom of the Series Directory.
The title of the workfile shows the user-defined name as well as the location of the saved
workfile. If not saved, it shows a generic name (i.e.Workfile1). A workfile can contain any
number of series copied from the official database, generated by the user or imported from
another source. It only has a two-level hierarchy display which is different from the official
database that has three-level.
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Workfile name and its location

Original series copied from the official database

2.23: Creating and Adding to Workfiles
You can use the function “Copy to Workfile” in the Edit menu to create a workfile.
To copy data series and/or table headings to a workfile, follow the steps below:
1. Select expanded tables or individual data series accordingly.
2. Choose from the Edit menu, “Copy to Workfile” or right click the mouse, then
choose “Copy to Workfile” or press “Ctrl + W”.
3. When the “Copy to Workfile” dialogue appears, select “New Workfile” to transfer
the selection to a new workfile or alternatively select an open workfile. If the latter
option is chosen, dXtime will add the newly copied data to the bottom of the series
directory. Click “OK”, the new workfile is created or the open one is added onto.
4. From the Open Windows panel on the left, click on your newly created workfile to
open.
Append selected
series/table to an opened
workfile

Open a new workfile
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Newly copied and appended data table from the official database
**Note:
The “Copy to Workfile” feature also works when the active window is either a Data
Table or Graph. All selected series will similarly be appended to the selected workfile.
Viewing Dashboards
Dashboards can be created in Workfiles for the purpose of displaying a set of memorized
Graphs together. Dashboards can be viewed by using “View” and “Dashboards”. You can
place the graphs under different subjects by adding new dashboards:

2.24: Saving and Retrieving Workfiles
Workfiles are saved and retrieved using the File menu. “Save workfile” and “Save workfile
as” save the workfile to a work folder in …\Dxw_EE\Dxdata\Work which was created
when the program was installed.
Users can also provide a description or other information for the workfile under “Summary
Information” dialogue when saving the workfile. One can save the workfile(s) in any
specified location by changing the path and “Open workfile” to locate saved workfiles.

User can provide description
for the workfile
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2.25: Editing Workfiles
Most editing functions are carried out under the Edit menu. Series may be moved or
copied to different locations within the series directory. New series may be inserted
and/or calculated and unwanted series deleted. Table headings may be inserted to change
the series directory into a 2-level hierarchy display.
**Note:
The original series copied from the official database should never be deleted from the
workfile. Otherwise, any calculated series based on these raw series would not be regenerated. Original series even though used for more than one calculation need to appear
only once in the workfile.
Copying and Moving Tables/Series
Series and table headings can be copied and moved using “Copy” and “Move” respectively.
Both operations can be preformed either within a workfile or across different workfiles. To
copy or move series, follow the steps below:
1. Select the series or table headings.
2. Choose “Edit” in menu bar, then “Copy”.
3. Move the flashing border to the desired location within in the same workfile or to a
different workfile.
4. Press “Enter” to paste the selection into the selected location.
Inserting and Deleting Series
In Edit menu, choose “Insert” to insert a blank series in a workfile. The “Insert Series”
dialogue will prompt for step by step information.
Step 1:

Step 2:

Step 3:

Step 4:

18

Step 5: Enter data by clicking on F2 (edit mode)

User generated series as below (s1, s2, s3)

Use the “Delete” option to permanently delete series or table headings from the workfile.

**Note:
Pressing the “Delete” key will not delete the series from the database.
Editing Series Description
Use “Text” in “Edit” menu or press “F2” to go into text edit mode. Users can modify text
elements such as description, identifier, unit or formula. Use “Insert heading” to insert a
new table heading. The newly inserted heading will have an expander (+/-) next to it.
When data series are moved under this new heading, it will produce a collapsible table
similar to that in the official database.
**Note:
While series descriptions for the original series can be edited, the series identifier cannot
be tempered with. Press “Tab” to move to next text target under edit mode. After the text
is edited, press “Enter” to save the change or press “Esc” to abort the change.
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Editing Data
When data series are viewed in Data Table mode within a workfile, data observations can
be edited. Use “New observation” under the “Data” menu to insert a new observation.
This is a quick way to include extra observations such as user-defined forecasts or to
modify observations without actually affecting the official database.
To add a range of new observations, use “Timeframe” under the Options menu. A range
of new blank cells will be added to the series by setting the end date as a future date.
Press “F2” to input the observations. To edit an existing observation in a Data Table,
select the observation and then choose “Edit mode” from the Edit menu or press “F2”.
Press “Enter” to save the changes.
**Note:
Data tables are adopted by dXtime for editing and viewing data series within a workfile.

2.26: Updating Workfiles
dXtime simplifies the process of updating series in workfiles by remembering the links
between the series and the official database. Updating can be set to either manual or
automatic.
To update the series manually, follow the steps below:
1. Open the workfile.
2. Select the series that needs to be updated
3. From the Series menu, choose “Update Linked Series” to refresh data observations
from the official database or “Recalculate” to regenerate calculated series.
This update method is ideal to prevent observations from being updated or replaced by
official updates.
To update automatically, follow the steps below:
1. Open the workfile.
2. Select “Maintain workfile” in the “File” menu and “Regenerate”.
3. Open “Regenerate workfile” dialogue box.
4. Choose “Regenerate automatically”, then click “Go”
5. Save workfile.
The “Regenerate workfile” dialogue box allows the user to select different update settings
for the workfile. “Regenerate automatically” will set the workfile to update and
recalculate all series automatically each time it is open.
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**Note:
The workfile has to be saved to memorize the update settings.

2.27：In-house databases
An In-house database allows a set of Workfiles produced as a database which can be shared
with other users within your organization. In-house databases share many features in
common with official databases, provide controlled, read-only, access to the contents of the
underlying Workfiles. They are managed by one, or a few members by assembling and
maintaining the underlying Workfiles. At appropriate intervals, the maintainer publishes
these Workfiles, packaged as one or more in-house databases, to the organization's shared
database directory.
**Note:
In-house databases are only accessible by licensed dXtime workstations within the
organization. They may not be distributed outside of the organization.
In-house databases work cycle
When working with in-house databases you will typically:
1. create Workfiles containing the time series to be published. These time series
may be sourced from official databases, imported from spreadsheets (or other
sources), or generated using dXtime's extensive series operations;
2. use the In-house Databases dialog box to create a new database definition;
Choose the File > Manage Databases > In-house Databases command to
display the In-house Databases dialog box. This dialog box lists your existing inhouse databases, lets you create and edit database definitions, and publish those
in-house databases at appropriate times.
The list of available in-house database definition
Open a new database
definition
Edit the definition of
the highlighted
database
Publish the
highlighted database
Locate the in-house
database definition
files and they will be

displayed within
the list of
Databases
The name of the in-house database definition file
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3. use the Edit Database Definition dialog box to identify the Workfiles to be
published as part of the in-house database;

4. use the In-house Databases dialog box to publish the database to the official
databases directory;
5. use standard dXtime updating facilities to update the Workfiles whenever
newer data becomes available;
6. repeat step 5 to re-publish the updated Workfiles.

2.3: Data Manipulation
Besides some common data manipulations (examples given from 2.31 to 2.36 below),
dXtime 5.4 EMED Edition is now capable of applying more advanced and sophisticated
data manipulations (examples given from 2.37 to 2.38 below) with the help of built in
analytical tools found in the “Series” menu. These operations can be applied in the
Official Database or Workfile environment.
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2.31: Frequency Changes
“Transform Frequency” enables the change of frequency from higher to lower or vice
versa of the selected series.
To go from higher to lower frequency, user can choose aggregation transformation method,
i.e. Total, Average, First and so on.

To specify characteristics of
the new series

To go from lower to higher
frequency, user can choose
disaggregation transformation

Formula Syntax of the operation

2.32: Percentage Changes
“Changes” calculates percentage change, differences or growth rate for selected series
over a year or period on period. User can specify the number of periods and the annual
rate if “Period on Period” is chosen.
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Choose type of change

Choose period of calculation and enter
number of periods
Check to have the change expressed as an
annual rate of change
Check to turn percentage change and
growth rate series back into levels

2.33: Time Series Trends
“Sums” enables the user to calculate simple moving average and other summations.
Enter the number of periods (1 or more) over
which Moving Averages or Rolling Sums are
to be calculated

Initial value and depreciation rate used to
capitalize series
Moving average returns a series equal to the average of series over an interval defined
by the number of periods
Rolling sum returns a series equal to the sum of series over an interval defined by the
number of periods
Accumulate returns a series equal to the cumulative sum to date of the series
Capitalize returns a series which is a capitalization of series based on the initial value
and the depreciation rate

“Smoothing” calculates center moving average and other smoothing adjustments.
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Centered moving average returns a series equal to the
average of series over an interval defined by the number
of periods.
Enter the periods over which Centered moving average
is to be calculated

Henderson moving
average returns a series
equal to a weighted average
of series over an interval
defined by the number of
periods, and centered on the
current observation from the
series.
Enter the number of terms
for Henderson Moving
Average to be calculated
Exponential smoothing
returns a series equal to a
weighted average of the
current observation from the
series and the previous
observation from the newly
calculated series
Enter a value for the
smoothing constant used for
Exponential smoothing

Hodrick-Prescott filter
The Hodrick-Prescott filter is a linear filter widely used in the identification and analysis
of business cycles. The HP filter can now be used to decompose a series into its “trend”
and “cycle” components. X(t) = M(t) + C(t)
The decomposition is performed by minimizing a loss function with two components;
one which penalizes poor fit (of the trend to the parent series), and the other which
penalizes lack of smoothness in the trend. The trade-off between these two criteria is
regulated by the parameter lambda. As lambda approaches 0, M(t) approaches X(t),
while as lambda approaches infinity, M(t) approaches a linear trend.
**Note:
Application of the Hodrick-Prescott filter requires that the parent series contain no
missing observations.
TRAMO-SEATS model
TRAMO-SEATS is a modeling methodology widely used for the seasonal adjustment of
time series, and is capable of decomposing a series into trend, seasonal and irregular
components. Choosing this option will cause the trend output to be saved.
**Note:
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Choose the Configure button if you wish to save additional model outputs as well as the
trend. For more information, please refer to 2.38.

2.34: Indices Adjustments
“Index” command enables users to calculate indexes for selected series. The new series
are index numbers with the specified base value starting at the base date. This function
can also be used to convert a value series into an index series.
The base can be defined over a
number of periods.

Base value (1-1000) used for the
index base

2.35: Math Functions & Arithmetic Operations
“Math Functions” command calculates various mathematical functions.
Returns a series equal to the
natural log (logarithm to the
base e) of the series

Returns a series equal to
the (base 10) antilogarithm
of the series
Returns a series
equal to the square
root of the series

Returns a series equal to
the denominator of the
series.

Returns a series
equal to the
logarithm to the base
10 of the series

Returns a series equal to the
exponential constant (e) to a
power equal to the value of series

“Arithmetic operations” command enables different operations between two series or
with a constant.
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Chose arithmetic operation

Chose arithmetic operation
and a constant

2.36: Series Adjustments
“Adjust Series” command enables users to extend history of the series.
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Returns a series in which each
observation is the value in the
specified lagged period

Returns a series where missing
observations are replaced in the
manner specified by chosen
method
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Returns a series in which all
occurrences of value are replaced
by replacements

Returns a series counting only
those observations that fall within
the sub-sample period defined by
the beginning and ending dates

Returns a series containing
exactly the same data but with a
different frequency and/or a
different sample period

Returns a series containing all the
observations from the Y series
together with observations from
where the two series do not overlap
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Returns a series containing all
observations from Y series
together with observations
adjusted by a factor equal to the
average ratio of the two series
where they overlap

Returns a series in which the
observations are rounded to the
number of places specified by the
decimals

Standardize the scaling of the selected
series. New series are generated
where each observation is a linear
transformation of the corresponding
observation of the parent series.
Trim observations from, or extend the
ends of, the selected series. Trimming
can be used to remove unwanted
observations (such as zeros)
appearing at the start or end of the
series. Padding can be used to extend
the sample period of series
To trim values from
the series beginning,
series end or both.
To pad out the series
to the specified dates.
Check this box to
automatically pad the series
out to the current date.
30

2.37: Advanced Features

“Contribution to Growth” command calculates the contribution of the selected
"component" series to the growth of the aggregate. The new series created represent an
additive decomposition of the percentage change (growth) in the aggregate series.
Choose over a-year or
per-period calculation

Specify the series to be
used as the aggregate,
or have it generated as
the sum of the selected
series.
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“Period to Date” command to calculate the year-to-date or similar accumulation of all
selected series. New series are created in which each observation is the sum of all
observations of the parent series for the respective year (or quarter, or month, etc.) up to
and including the date of that observation.
Specify the frequency of
the accumulated series.

Check this box to undo the
effects of an aggregation and
recover the series level.

“Merge” command to merge a set of lower frequency series into a single higher frequency
series. For example, if you have a set of Annual series, where each series contains
observations corresponding to a single month of the year (January, February, March, etc.),
then the Merge command can be used to produce a single Monthly series containing all of
the data observations.
Before executing the Merge command, you need to ensure that lower frequency series are
arranged in the correct order (January, February, etc. in the example given).
Specify the frequency of the merged series
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2.38: TRAMO-SEATS

dXtime includes a powerful seasonal adjustment capability built on top of the TRAMOSEATS time series software, which can also be used to generate other series, such as trends
and forecasts.
TRAMO (Time Series Regression with Arima Noise, Missing Observations and Outliers)
is a program for estimating, forecasting and interpolating time series regression models.

SEATS (Signal Extraction in Arima Time Series) is a program for decomposing a
time series into various “unobserved” components, such as the trend, seasonal and
irregular. It typically receives as input the original series, along with the ARIMA
model description of the series.
TRAMO and SEATS are designed to work together, with TRAMO “cleaning up” the
original series, and identifying an appropriate ARIMA model, and the results being passed
onto SEATS for decomposition into various components. Both programs offer many
configuration options, but also offer the ability to model series in a fully automatic way.

2.39: User Defined Formulae
After inserting a blank series, users can use “Formula” from the Edit menu to modify
and/or setup their user-defined formulae. User can modify the formula of any calculated
series in a workfile.
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Formula editing window

Paste series ID into
formula after selection

Paste function into
formula after selection

Choose from a list of
available functions

Choose from all available series in the work file

For an explanation of other data manipulation tools, please refer to the online Help.
**Note:
There is a difference between “Transform Frequency” under the Series menu and
“Timeframe” under the Option menu. “Transform Frequency” physically converts the
underlying series into a new series with a different frequency. “Timeframe” is primarily
used to select sub-sets of data from the original series; it does not affect the actual
frequency of the data series.

2.4: Data Export
dXtime offers 3 ways to transfer data and graphs from the system to another application
such as spreadsheets, word processors and other Windows compatible applications.

2.41: Copy/Paste and Printing
One can choose “Copy to Clipboard” under the Edit menu to transfer data and graphs
using the Windows Clipboard. The dialogue box allows the user to choose the categories
of data to transfer and to set the timeframe. The copied information can then be pasted
directly into the destined application.
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Choose categories of
data to transfer to
Windows Clipboard

**Note:
The amount of data that can be transferred successfully is dependent on the memory
limitation of the Windows Clipboard.
The contents of the active window can be printed using “Print” under the File menu or
“Print” icon of the menu bar. Similar to other Windows application, the user can preview
the content before sending it to the printer.

2.42: Export Function
To overcome the Windows Clipboard’s memory limitation, dXtime provides an export
function to transfer larger volume of data from the official database to other applications.
The following applications and formats are supported:
Spreadsheets:
1-2-3 (wk1, wks), Excel 4.0, 95, 97-2003 (xls), Quattro (wkq), Comma-separated Values
(csv) in a format suitable for import into MATLAB
Images:
PNG, GIF, JPEG
Econometrics:
AREMOS, ESP, Microfit, MicroTSP, PC-GIVE, RATS, Shazam, Soritec, TSP
Statistics:
Minitab, SAS, Quattro, SPSS/PC, Stata, Systat
Interchange:
XML, DIF, SYLK, CSV, Data by Variable, Data by Observation, Univariate, Time
Series Format
Other:
dBASE III, GAUSS, Javelin
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Select category and
format from these
two lists.

After selecting the data series either from the official database or workfile, you can press
the XLS icon on the menu bar or go to File > Export… to export the selected information
into files of other applications.

2.43: dXdata add-in for Microsoft Excel
dXtime 5.4 EMED Edition includes a dedicated dXdata add-in for use with Microsoft
Excel. The add-in makes it simple to access time series data from within Excel Workbooks,
and to keep those Workbooks updated as new observations arrive. The add-in can retrieve
data from both Official Databases and Workfiles.
The dXdata add-in can be used independently of dXtime. However, you may find it
convenient to use dXtime to:
• Maintain series in Workfiles, which the add-in can then access;
• Simplify the initial creation of dXdata Sheets, within Excel, using the Edit > Copy
to Excel command.

Refer to 2.43.2,
“Create dxdata Sheet”

2.43.1: Installation
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The dXdata add-in must be installed within Microsoft Excel before it can be used. After
installation of dXtime 5.4 EMED Edition, the installer for the add-in can be found in the
install subdirectory of the main dXtime program directory. After running the installer
1. Start Microsoft Excel.
2. Choose the Tools > Add-Ins command
3. In the Add-Ins dialog box, choose the Browse button.
4. Navigate to the folder which you specified when running the dXdata add-in
installation, select the file dxdata.xla, and click OK.
5. In the Add-Ins dialogue box, make sure that a check appears beside the dXdata entry,
then click OK.
6. The add-in should now be installed. Verify this by checking that the dXdata menu
now appears within the main Excel menu bar.

The dXdata add-in for Microsoft Excel allows you to easily access dX time series data from
within Microsoft Excel. Using the add-in, you can create dedicated Worksheets containing
dX data within your Excel Workbooks. These Worksheets can be easily updated as your
official databases and dX Workfiles are updated over time.
Each Worksheet you create with the dXdata add-in will contain time series from either a
single official database, or from a single dX Workfile. In the case of Workfiles, you can
choose to select series individually, or to access all series contained in a memorized Data
Table. It is not necessary to run dXtime when working with the add-in (though dXtime can
be used to simplify the initial creation of dXdata Worksheets).
2.43.2: Using the dXdata add-in
Make sure that the add-in is properly installed within Microsoft Excel (see Installation).
2.43.2.1 Exporting data to Microsoft Excel
Within Excel, choose the dXdata > Create dXdata Sheet command.
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In the Create dXdata Sheet dialog box, specify the Data Source (either an official database, or
a Workfile).

1.
2.

3.
4.

Under Data Source, specify the Database and series to be downloaded (or, in the case of
Workfiles, you may prefer to download entire memorized Data Tables).
Click “Paste from dXtime” to initiate the creation of a new dXdata Sheet. At this point,
the add-in will also fill the new Worksheet with time series data downloaded from the
dX database or Workfile.
Subsequently, you may click on the Edit button on the dXdata Sheet to modify the series
to be downloaded or change other settings (like the range of data to download).
Click the Update button on the dXdata Sheet to refresh it with the latest time series data
contained in the official database or Workfile.
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2.43.2.2 Importing data from Microsoft Excel:
With the new version of dXdata add-in, now you are able to import data from Microsoft
Excel by creating data connections. Data connections allow you to link time series stored in
Microsoft Excel workbooks and retrieve that data within a dXtime Workfile. The data
connections you make are updatable.
Creating and working with data connections generally involves the following steps:
1. Identify just what time series data stored in your spreadsheets you wish to link into
dXtime. In particular, you may need to create series Identifiers within your spreadsheets
to uniquely identify each series. Also, creation of range names corresponding to
important components of the data (Identifiers, Dates, Observations, etc.) is highly
recommended.
2. Within Excel, open the Workbook containing the data you wish to link, and use the
dXdata add-in Export to dXtime command to start the Export to dXtime Wizard. The
Wizard will allow you to specify which parts (ranges) of the workbook are to be linked
into dXtime.
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**Note:
You will need to save your file with an extension .ddc. A single DDC file can contain
multiple data connections, for example, if you wish to create connections to multiple
Worksheets in a single Excel Workbook.
3. Once the Wizard has finished creating the data connection, choose the dXtime File >
Connections command to open the new data connection within dXtime, and specify a
Workfile into which to store the linked time series.

4. Whenever the underlying spreadsheet data is updated, just open the Workfile in dXtime,
select the linked series, and use the Series > Updated Linked Series command to update
the Workfile's copy of the data.
5. If necessary, you can use the Export to dXtime Wizard (from within Excel) to edit an
existing connection, as well as create new connections.

3.0: dXupdate
dXupdate is responsible for retrieving and applying EMED database updates. dXupdate
performs two main tasks.
Update Retrieval
dXupdate can automatically retrieve EMED database updates:
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•

Using Web updating (HTTP protocol), a dedicated mailbox, or a dial-up
networking connection, if necessary.

•

At various intervals. Alternatively, you may manually check for new updates
whenever you wish.

**Note:
If, for whatever reason, you are unable to use either Web updating, or automatic e-mail
retrieval, then all you need do is arrange to have the database updates sent to a personal
mailbox. Whenever you receive mail messages, save the attachments containing the database
updates into the dXupdate Mail directory, and they will be processed automatically.
Update Processing
dXupdate periodically checks its Mail directory for newly arrived database updates and
processes them automatically. Update process:
•
•
•

Occurs either when they are retrieved by dXupdate or have been placed there by
some other e-mail program or by the user.
Occurs in the background and has minimal performance impact on your other work.
Does not interfere with dX users and their simultaneous access to the official
databases concerned.

3.1: Ways to Update EMED Databases
3.11: Web Updating to Download Updates
Web updating (using the HTTP protocol) is dXupdate's usual method of downloading
newly released EMED database updates. To use Web updating:
•

Make sure that the machine on which dXupdate is installed is able to access the
Internet using the HTTP protocol.

•

Ensure that the “Enable Web updating” box is selected in the “Updating” tab of
the “dXupdate Setup” dialog box.
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•
•
•

Select “Automatic database updating” or “Manual checking only” in the “Updating”
tab of the “dXupdate Setup” dialog box.
If access to the Internet via a proxy server is required, enter the proxy server details in
the “Web” tab of the “dXupdate Setup” dialog box.
If a dial-up connection to access the Internet is necessary, specify in the
“Connections” tab.

dXupdate will then periodically connect to the Internet and check for new updates. Users
can also initiate a connection at any time by clicking on the Update button in dXupdate's
main window.
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3.12: E-mail to Retrieve Updates
dXupdate can also retrieve database updates from a dedicated mailbox using either
Internet (POP3) or Windows Messaging (MAPI) protocols. To use e-mail retrieval:
•
•
•
•

Make arrangements with EMED to have the database updates sent to a dedicated
mailbox.
Use the “Mail” tab of the “dXupdate Setup” dialog box to enter the details of the
mailbox i.e. the profile name for Windows Messaging or the server name, user
name and password for POP3 access.
Ensure that the “Enable e-mail retrieval” box is selected in the “Updating” tab of
the “dXupdate Setup” dialog box.
Specify in the “Connections” tab if need to use a dial-up connection to access the
Internet.

dXupdate will then periodically connect to the dedicated mailbox and check for new
updates. Users can also initiate a connection at any time by using the “Update”, “Check
for new mail messages now” command in the dXupdate's main window.

Enable web updating to
download updates (3.11)

Select EMED database
updates automatically
or manually
Enable email updates
(3.12)

For users who cannot allocate a designated email account to receive the updates, they can
opt for manual updating:
•
•

Ensure that the “Manual checking only” box is selected in the “Updating” tab of
the “dXupdate Setup” dialog box.
Upon receiving the update attachments, save them into the default-processing
directory (i.e. C:\Dxw_EE\Dxdata\Admin\Mail).
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•

dXupdate will automatically process the updates.

3.2: dXupdate Reports
The “Update History” provides a record of EMED database updates recently received and
processed. It can be accessed by clicking on the “Reports” button in the dXupdate main
window. The history presents information on each update in a number of columns, as well
as detail information displayed at the bottom of the window of the selected update.
Database
Shows the short name of the EMED database which is being updated.
Date, Time
Shows the date and time when the database update was created. Times are given as the
local time of the EMED. Time zone information appears as the difference between the local
time and Greenwich Mean Time (GMT).
File
Shows the name of the database update file. If for some reason a file is not received intact,
users may contact EMED to request for the file to be re-transmitted.
Versions
Shows database update files that contain one or more incremental updates to a particular
EMED database. These updates are numbered sequentially and the database versions to
which they correspond are displayed in this column.
**Note:
On occasion users may receive an update file which contains complete replacement files
rather than incremental updates. In this event the Versions field will display "n.a." (not
applicable).
Status
Indicates the overall status of the database update. The status can be one of the following:
OK

The update has been successfully unpacked.

Wait

The update is in the process of being unpacked.

Fail

Some type of error has prevented the update from being processed.

Partial

Not all of the component files in the update could be unpacked.

Ignore

This update has been received previously.

Pending

The update cannot be unpacked yet because one or more prior
updates have been missed.
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When the processing is completed, and if one or more database updates appear with a
Wait or Fail status, select the update (by clicking on its row in the list of updates) and
check the summary error message which appears under “Comment”.

Comment of
database update

4.0: Database Notes
4.1: dXnotes
dXnotes can be accessed within dXtime to retrieve release notes and explanatory notes
for EMED Official Databases. There are two ways to start dXnotes. Press the Notes icon
on the Menu bar or press Ctrl+F1
Notes icon

45

Whenever the Notes command is executed, dXtime attempts to display any notes pertaining
to the active database topic or section. Afterwards, the Note drop-down list in the Notes
toolbar may be used to access other available notes for the database such as:
•
•
•
•
•

Database Notes: Provide information such as General Notes, Database Coverage,
Coding Convention, and so on.
Today’s Releases: Shows data which will be released on the present day as
indicated by the official sources.
This Week’s Releases: Shows data which will be released in the present week as
indicated by the official sources.
Next Week’s Releases: Shows data which will be released in the following week as
indicated by the official sources.
Newly Added Data: Provide information about the data which are newly added to
the database.
Notes drop down menu
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